high8.1
CVE-2022-24759
`@chainsafe/libp2p-noise` contains TypeScript implementation of noise protocol, an encryption protocol used in libp2p.
Impact
`@chainsafe/libp2p-noise` contains TypeScript implementation of noise protocol, an encryption protocol used in libp2p. `@chainsafe/libp2p-noise` before 4.1.2 and 5.0.3 does not correctly validate signatures during the handshake process. This may allow a man-in-the-middle to pose as other peers and get those peers banned. Users should upgrade to version 4.1.2 or 5.0.3 to receive a patch. There are currently no known workarounds.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Chainsafe | Js-Libp2p-Noise | before 4.1.2 from 5.0.0 before 5.0.3 |
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/ChainSafe/js-libp2p-noise/pull/130
- https://github.com/ChainSafe/js-libp2p-noise/releases/tag/v5.0.3
- https://github.com/ChainSafe/js-libp2p-noise/security/advisories/GHSA-j3ff-xp6c-6gcc
- https://github.com/ChainSafe/js-libp2p-noise/pull/130
- https://github.com/ChainSafe/js-libp2p-noise/releases/tag/v5.0.3
- https://github.com/ChainSafe/js-libp2p-noise/security/advisories/GHSA-j3ff-xp6c-6gcc