CVE-2022-24783
Sandbox bypass leading to arbitrary code execution in Deno
Impact
### Impact The versions of Deno between release 1.18.0 and 1.20.2 (inclusive) are vulnerable to an attack where a malicious actor controlling the code executed in a Deno runtime could bypass permission checks and execute arbitrary shell code. There is **no** evidence that this vulnerability has been exploited in the wild. This vulnerability does **not** affect users of Deno Deploy. ### Patches The vulnerability has been patched in Deno 1.20.3. ### Workarounds There is no workaround. All users are recommended to upgrade to 1.20.3 immediately --- The cause of this error was that certain FFI operations did not correctly check for permissions. The issue was fixed in [this](https://github.com/denoland/deno/pull/14115) pull request.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| rust | deno | >= 1.18.0, < 1.20.3 | 1.20.3 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Deno | Deno | from 1.18.0 before 1.20.3 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/denoland/deno/security/advisories/GHSA-838h-jqp6-cf2f
- https://github.com/advisories/GHSA-838h-jqp6-cf2f
- https://nvd.nist.gov/vuln/detail/CVE-2022-24783
- https://github.com/denoland/deno/releases/tag/v1.20.3
- https://github.com/denoland/deno/pull/14115
- https://github.com/denoland/deno/commit/fcfce1bb869fddc629e6d889d6ba1328b80b0dcf
- https://github.com/denoland/deno/compare/v1.20.2...v1.20.3