NetSight
high7.5

CVE-2022-24822

Denial of Service vulnerability in @podium/layout and @podium/proxy

Impact

### Impact An attacker using the `Trailer` header as part of the request against proxy endpoints has the ability to take down the server. All Podium layouts that include podlets with proxy endpoints are affected. ### Patches `@podium/layout` which is the main way developers/users are vulnerable to this exploit, has been patched in version `4.6.110`. All earlier versions are vulnerable. `@podium/proxy` which is the source of the vulnerability and is used by `@podium/layout` has been patched in version `4.2.74`. All earlier versions are vulnerable. ### Workarounds It is not easily possible to work around this issue without upgrading. We recommend upgrading `@podium/layout` and/or `@podium/proxy` as soon as possible. ### For more information If you have any questions or comments about this advisory: * Open an issue in [podium-lib/issues](https://github.com/podium-lib/issues) ### Credits The vulnerability was reported by [krynos](https://hackerone.com/krynos) from [Ercoli Consulting](https://www.ercoliconsulting.eu/) via FINN.no's private bug bounty program

Affected packages

EcosystemPackageAffectedFixed in
npm@podium/layout< 4.6.1104.6.110
npm@podium/proxy< 4.2.744.2.74

Affected products

VendorProductAffected versions
FinnPodium Layout
before 4.6.110
FinnPodium Proxy
before 4.2.74

Weakness classification

References