NetSight
high7.5

CVE-2022-24836

Nokogiri Inefficient Regular Expression Complexity

Impact

## Summary Nokogiri `< v1.13.4` contains an inefficient regular expression that is susceptible to excessive backtracking when attempting to detect encoding in HTML documents. ## Mitigation Upgrade to Nokogiri `>= 1.13.4`. ## Severity The Nokogiri maintainers have evaluated this as [**High Severity** 7.5 (CVSS3.1)](https://www.first.org/cvss/calculator/3.1#CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H). ## References [CWE-1333](https://cwe.mitre.org/data/definitions/1333.html) Inefficient Regular Expression Complexity ## Credit This vulnerability was reported by HackerOne user ooooooo_q (ななおく).

Affected packages

EcosystemPackageAffectedFixed in
rubygemsnokogiri< 1.13.41.13.4

Affected products

VendorProductAffected versions
NokogiriNokogiri
before 1.13.4
FedoraprojectFedora
Versions 34, 35, 36
DebianDebian Linux
Versions 9.0, 10.0
AppleMacos
from 13.0 before 13.1

Weakness classification

References