CVE-2022-24858
NextAuth.js default redirect callback vulnerable to open redirects
Impact
`next-auth` v3 users before version 3.29.2 are impacted. (We recommend upgrading to v4 in most cases. See our [migration guide](https://next-auth.js.org/getting-started/upgrade-v4)).`next-auth` v4 users before version 4.3.2 are impacted. Upgrading to 3.29.2 or 4.3.2 will patch this vulnerability. If you are not able to upgrade for any reason, you can add a configuration to your `callbacks` option: ```js // async redirect(url, baseUrl) { // v3 async redirect({ url, baseUrl }) { // v4 // Allows relative callback URLs if (url.startsWith("/")) return new URL(url, baseUrl).toString() // Allows callback URLs on the same origin else if (new URL(url).origin === baseUrl) return url return baseUrl } ``` If you already have a `redirect` callback, make sure that you match the incoming `url` origin against the `baseUrl`.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | next-auth | < 3.29.2 | 3.29.2 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Nextauth.Js | Next-Auth | from 3.0.0 before 3.29.2 from 4.0.0 before 4.3.2 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/nextauthjs/next-auth/security/advisories/GHSA-f9wg-5f46-cjmw
- https://next-auth.js.org/configuration/callbacks#redirect-callback
- https://next-auth.js.org/getting-started/upgrade-v4
- https://github.com/advisories/GHSA-f9wg-5f46-cjmw
- https://nvd.nist.gov/vuln/detail/CVE-2022-24858
- https://github.com/nextauthjs/next-auth/commit/6e15bdcb2d93c1ad5ee3889f702607637e79db50
- https://github.com/nextauthjs/next-auth/releases/tag/next-auth%40v4.3.2