high7.2
CVE-2022-24871
Server-Side Request Forgery (SSRF) in Shopware
Impact
### Impact The attacker can abuse the Admin SDK functionality on the server to read or update internal resources. ### Patches We recommend updating to the current version 6.4.10.1. You can get the update to 6.4.10.1 regularly via the Auto-Updater or directly via the download overview. https://www.shopware.com/en/download/#shopware-6 ### Workarounds For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | shopware/platform | <= 6.4.9.0 | 6.4.10.1 |
| composer | shopware/core | <= 6.4.9.0 | 6.4.10.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Shopware | Shopware | before 6.4.10.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-04-2022
- https://github.com/shopware/platform/commit/083765e2d64a00315050c4891800c9e98ba0c77c
- https://github.com/shopware/platform/security/advisories/GHSA-7gm7-8q8v-9gf2
- https://github.com/advisories/GHSA-7gm7-8q8v-9gf2
- https://nvd.nist.gov/vuln/detail/CVE-2022-24871