high7.2
CVE-2022-24899
Cross site scripting via canonical tag in Contao
Impact
### Impact Untrusted users can inject malicious code into the canonical tag, which is then executed on the web page (front end). ### Patches Update to Contao 4.13.3. ### Workarounds Disable canonical tags in the root page settings. ### References https://contao.org/en/security-advisories/cross-site-scripting-via-canonical-url ### For more information If you have any questions or comments about this advisory, open an issue in [contao/contao](https://github.com/contao/contao/issues/new/choose).
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | contao/core-bundle | >= 4.13.0, < 4.13.3 | 4.13.3 |
| composer | contao/contao | >= 4.13.0, < 4.13.3 | 4.13.3 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Contao | Contao | from 4.13.0 through 4.13.2 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://contao.org/en/security-advisories/cross-site-scripting-via-canonical-url.html
- https://github.com/contao/contao/commit/199206849a87ddd0fa5cf674eb3c58292fd8366c
- https://github.com/contao/contao/security/advisories/GHSA-m8x6-6r63-qvj2
- https://github.com/advisories/GHSA-m8x6-6r63-qvj2
- https://nvd.nist.gov/vuln/detail/CVE-2022-24899
- https://github.com/FriendsOfPHP/security-advisories/blob/master/contao/contao/CVE-2022-24899.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/contao/core-bundle/CVE-2022-24899.yaml