NetSight
medium6.1

CVE-2022-24948

Cross-site Scripting in Apache JSPWiki

Impact

A carefully crafted user preferences for submission could trigger an XSS vulnerability on Apache JSPWiki, related to the user preferences screen, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.11.2 or later.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.jspwiki:jspwiki-main< 2.11.22.11.2

Affected products

VendorProductAffected versions
ApacheJspwiki
before 2.11.2

Weakness classification

References