NetSight
high7.0

CVE-2022-25768

Mautic vulnerable to Improper Access Control in UI upgrade process

Impact

### Impact The logic in place to facilitate the update process via the user interface lacks access control to verify if permission exists to perform the tasks. Prior to this patch being applied it might be possible for an attacker to access the Mautic version number or to execute parts of the upgrade process without permission. As upgrading in the user interface is deprecated, this functionality is no longer required. ### Patches Upgrade to 4.4.13 or 5.1.1 or later. ### Workarounds None. ### For more information If you have any questions or comments about this advisory: * Email us at [security@mautic.org](mailto:security@mautic.org)

Affected packages

EcosystemPackageAffectedFixed in
composermautic/core-lib>= 1.1.3, < 4.4.134.4.13
composermautic/core>= 1.1.3, < 4.4.134.4.13

Affected products

VendorProductAffected versions
AcquiaMautic
from 1.1.3 before 4.4.13
from 5.0.0 before 5.1.1

Weakness classification

References