high7.8
CVE-2022-25770
Mautic has insufficient authentication in upgrade flow
Impact
### Impact Mautic allows you to update the application via an upgrade script. The upgrade logic isn't shielded off correctly, which may lead to vulnerable situation. This vulnerability is mitigated by the fact that Mautic needs to be installed in a certain way to be vulnerable ### Patches Please upgrade to 4.4.1 or 5.1.1 or later. ### Workarounds None. ### For more information If you have any questions or comments about this advisory: * Email us at [security@mautic.org](mailto:security@mautic.org)
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | mautic/core | >= 1.0.0-beta3, < 4.4.13 | 4.4.13 |
| composer | mautic/core-lib | >= 1.0.0-beta3, < 4.4.13 | 4.4.13 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Acquia | Mautic | from 1.0.1 before 4.4.13 from 5.0.0 before 5.1.1 Version 1.0.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/mautic/mautic/security/advisories/GHSA-qf6m-6m4g-rmrc
- https://github.com/advisories/GHSA-qf6m-6m4g-rmrc
- https://github.com/mautic/mautic/commit/73b18e9a434a28e528fe0e3d03620e7367bdcdca
- https://github.com/mautic/mautic/commit/aee7bfb7510a83acf178a7f02da9661c040e9abf
- https://nvd.nist.gov/vuln/detail/CVE-2022-25770