NetSight
high7.5

CVE-2022-25927

ReDoS Vulnerability in ua-parser-js version

Impact

### Description: A regular expression denial of service (ReDoS) vulnerability has been discovered in `ua-parser-js`. ### Impact: This vulnerability bypass the library's `MAX_LENGTH` input limit prevention. By crafting a very-very-long user-agent string with specific pattern, an attacker can turn the script to get stuck processing for a very long time which results in a denial of service (DoS) condition. ### Affected Versions: From version `0.7.30` to before versions `0.7.33` / `1.0.33`. ### Patches: A patch has been released to remove the vulnerable regular expression, update to version `0.7.33` / `1.0.33` or later. ### References: [Regular expression Denial of Service - ReDoS](https://owasp.org/www-community/attacks/Regular_expression_Denial_of_Service_-_ReDoS) ### Credits: Thanks to @Snyk who first reported the issue.

Affected packages

EcosystemPackageAffectedFixed in
npmua-parser-js>= 0.8.0, < 1.0.331.0.33

Affected products

VendorProductAffected versions
Ua-Parser-Js ProjectUa-Parser-Js
from 0.7.30 before 0.7.33
from 0.8.1 before 1.0.33

Weakness classification

References