NetSight
medium6.1

CVE-2022-28730

Apache JSPWiki XSS due to incomplete patch for CVE-2021-40369

Impact

A carefully crafted request on AJAXPreview.jsp could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. This vulnerability leverages CVE-2021-40369, where the Denounce plugin dangerously renders user-supplied URLs. Upon re-testing CVE-2021-40369, it appears that the patch was incomplete as it was still possible to insert malicious input via the Denounce plugin. Apache JSPWiki users should upgrade to 2.11.3 or later.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.jspwiki:jspwiki-main< 2.11.32.11.3

Affected products

VendorProductAffected versions
ApacheJspwiki
before 2.11.3

Weakness classification

References