CVE-2022-30123
Possible shell escape sequence injection vulnerability in Rack
Impact
There is a possible shell escape sequence injection vulnerability in the Lint and CommonLogger components of Rack. This vulnerability has been assigned the CVE identifier CVE-2022-30123. Versions Affected: All. Not affected: None Fixed Versions: 2.0.9.1, 2.1.4.1, 2.2.3.1 ## Impact Carefully crafted requests can cause shell escape sequences to be written to the terminal via Rack's Lint middleware and CommonLogger middleware. These escape sequences can be leveraged to possibly execute commands in the victim's terminal. Impacted applications will have either of these middleware installed, and vulnerable apps may have something like this: ``` use Rack::Lint ``` Or ``` use Rack::CommonLogger ``` All users running an affected release should either upgrade or use one of the workarounds immediately. ## Workarounds Remove these middleware from your application
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| rubygems | rack | <= 2.0.9.0 | 2.0.9.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Rack Project | Rack | before 2.0.9.1 from 2.1.0 before 2.1.4.1 from 2.2.0 before 2.2.3.1 |
| Debian | Debian Linux | Version 11.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://discuss.rubyonrails.org/t/cve-2022-30123-possible-shell-escape-sequence-injection-vulnerability-in-rack/80728
- https://security.gentoo.org/glsa/202310-18
- https://security.netapp.com/advisory/ntap-20231208-0011/
- https://www.debian.org/security/2023/dsa-5530
- https://github.com/advisories/GHSA-wq4h-7r42-5hrr
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rack/CVE-2022-30123.yml
- https://groups.google.com/g/ruby-security-ann/c/LWB10kWzag8
- https://github.com/rack/rack/commit/b426cc224908ec6ed6eb8729325392b048215d88
- https://nvd.nist.gov/vuln/detail/CVE-2022-30123