NetSight
high6.5

CVE-2022-31020

Indy's NODE_UPGRADE transaction vulnerable to remote code execution

Impact

### Impact The `pool-upgrade` request handler in Indy-Node `<=1.12.4` allows an improperly authenticated attacker to remotely execute code on nodes within the network. Network operators are strongly encouraged to upgrade to the latest Indy-Node release `>=1.12.5` as soon as possible. ### Patches The `pool-upgrade` request handler in Indy-Node `>=1.12.5` has been updated to properly authenticate `pool-upgrade` transactions before any processing is performed by the request handler. The transactions are further sanitized to prevent remote code execution. ### Mitigations Network operators are strongly encouraged to upgrade to the latest Indy-Node release `>=1.12.5` as soon as possible. ### Acknowledgements Thank you to @shakreiner at CyberArk Labs for finding and responsibly disclosing this issue.

Affected packages

EcosystemPackageAffectedFixed in
pipindy-node>= 0, < 1.12.5rc11.12.5rc1

Affected products

VendorProductAffected versions
LinuxfoundationIndy-Node
through 1.12.4

Weakness classification

References