medium5.4
CVE-2022-31048
Cross-Site Scripting in TYPO3's Form Framework
Impact
> ### Meta > * CVSS: `CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N/E:F/RL:O/RC:C` (4.9) ### Problem It has been discovered that the Form Designer backend module of the Form Framework is vulnerable to cross-site scripting. A valid backend user account with access to the form module is needed to exploit this vulnerability. ### Solution Update to TYPO3 versions 8.7.47 ELTS, 9.5.35 ELTS, 10.4.29, 11.5.11 that fix the problem described above. ### Credits Thanks to Gabe Troyan who reported and fixed the issue. ### References * [TYPO3-CORE-SA-2022-003](https://typo3.org/security/advisory/typo3-core-sa-2022-003)
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | typo3/cms-core | >= 8.0.0, < 8.7.47 | 8.7.47 |
| composer | typo3/cms | >= 10.0.0, < 10.4.29 | 10.4.29 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Typo3 | Typo3 | from 8.0.0 before 8.7.47 from 9.0.0 before 9.5.35 from 10.0.0 before 10.4.29 from 11.0.0 before 11.5.11 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/TYPO3/typo3/commit/6f2554dc4ea0b670fd5599c54fd788d4db96c4a0
- https://github.com/TYPO3/typo3/security/advisories/GHSA-3r95-23jp-mhvg
- https://typo3.org/security/advisory/typo3-core-sa-2022-003
- https://github.com/advisories/GHSA-3r95-23jp-mhvg
- https://nvd.nist.gov/vuln/detail/CVE-2022-31048
- https://github.com/FriendsOfPHP/security-advisories/blob/master/typo3/cms-core/CVE-2022-31048.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/typo3/cms/CVE-2022-31048.yaml