NetSight
medium5.4

CVE-2022-31057

Authenticated Stored Cross-site Scripting in Shopware

Impact

### Impact Authenticated Stored XSS in Administration ### Patches We recommend updating to version 5.7.12. You can get the update to 5.7.12 regularly via the Auto-Updater or directly via the download overview. https://www.shopware.com/de/changelog-sw5/#5-7-12 For older versions you can use the Security Plugin: https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html ### References https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-06-2022

Affected packages

EcosystemPackageAffectedFixed in
composershopware/shopware< 5.7.125.7.12

Affected products

VendorProductAffected versions
ShopwareShopware
from 5.0.0 before 5.7.12

Weakness classification

References