NetSight
high7.5

CVE-2022-31121

Hyperledger Fabric vulnerable to Improper Input Validation in orderer/common/cluster consensus request

Impact

### Impact If a consensus client sends a malformed consensus request to an orderer it may crash the orderer node. This fix checks for the malformed consensus request and returns an error to the consensus client. ### Specific Go Packages Affected github.com/hyperledger/fabric/orderer/common/cluster ### Patches Fixed in v2.2.7 and v2.4.5. ### Workarounds None, users must upgrade to v2.2.7 or v2.4.5. ### References https://github.com/hyperledger/fabric/releases/tag/v2.2.7 https://github.com/hyperledger/fabric/releases/tag/v2.4.5 ### For more information If you have any questions or comments about this advisory: * Open an issue in [Hyperledger Fabric repository](https://github.com/hyperledger/fabric/issues) ### Credits Thank you to Haosheng Wang of OPPO ZIWU Security Lab for this disclosure.

Affected packages

EcosystemPackageAffectedFixed in
gogithub.com/hyperledger/fabric< 2.2.72.2.7

Affected products

VendorProductAffected versions
HyperledgerFabric
before 2.2.7
from 2.3.0 before 2.4.5

Weakness classification

References