medium5.4
CVE-2022-31148
Shopware vulnerable to persistent cross site scripting (XSS) in customer module
Impact
### Impact Persistent XSS in customer module ### Patches We recommend updating to the current version 5.7.14. You can get the update to 5.7.14 regularly via the Auto-Updater or directly via the download overview. For older versions you can use the Security Plugin: https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html ### References https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-07-2022
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | shopware/shopware | >= 5.7.0, <= 5.7.13 | 5.7.14 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Shopware | Shopware | from 5.7.0 before 5.7.14 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-07-2022
- https://github.com/shopware/shopware/commit/7875855005648fba7b39371a70816afae2e07daf
- https://github.com/shopware/shopware/security/advisories/GHSA-5834-xv5q-cgfw
- https://github.com/advisories/GHSA-5834-xv5q-cgfw
- https://www.shopware.com/en/changelog-sw5/#5-7-14
- https://nvd.nist.gov/vuln/detail/CVE-2022-31148