high7.5
CVE-2022-31157
LTI 1.3 Tool Library's function used to generate random nonces not sufficiently cryptographically complex before v5.0
Impact
### Impact The function used to generate random nonces was not sufficiently cryptographically complex. As a result values may be predictable and tokens may be forgable. ### Patches Users should upgrade to version 5.0 immediately ### Workarounds None.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | packbackbooks/lti-1-3-php-library | < 5.0 | 5.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Packback | Lti 1.3 Tool Library | before 5.0.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/packbackbooks/lti-1-3-php-library/security/advisories/GHSA-768m-5w34-2xf5
- https://github.com/advisories/GHSA-768m-5w34-2xf5
- https://github.com/packbackbooks/lti-1-3-php-library/commit/de19e8a0b28cdc7750fa3ca98471eeed26ba3e57
- https://openid.net/specs/openid-connect-core-1_0.html#IDToken
- https://nvd.nist.gov/vuln/detail/CVE-2022-31157