high7.5
CVE-2022-33977
untangle vulnerable to XML Entity Expansion
Impact
### Impact An attacker may be able to cause a denial-of-service (DoS) condition on the server on which the product is running. This affects untangle versions up to and including 1.2.0 ### Patches The problem has been fixed with version 1.2.1 ### Workarounds None ### References https://jvn.jp/en/jp/JVN30454777/ ### For more information If you have any questions or comments about this advisory: * Open an [issue](https://github.com/stchris/untangle/issues)
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | untangle | < 1.2.1 | 1.2.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Untangle Project | Untangle | through 1.2.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/stchris/untangle
- https://github.com/stchris/untangle/releases/tag/1.2.1
- https://jvn.jp/en/jp/JVN30454777/
- https://github.com/advisories/GHSA-7xr3-6ggc-wc9p
- https://github.com/stchris/untangle/security/advisories/GHSA-7xr3-6ggc-wc9p
- https://nvd.nist.gov/vuln/detail/CVE-2022-33977
- https://github.com/pypa/advisory-database/tree/main/vulns/untangle/PYSEC-2022-243.yaml
- https://jvn.jp/en/jp/JVN30454777