medium4.3
CVE-2022-34817
Cross-Site Request Forgery in Jenkins Failed Job Deactivator Plugin
Impact
A cross-site request forgery (CSRF) vulnerability in Jenkins Failed Job Deactivator Plugin 1.2.1 and earlier allows attackers to disable jobs. This CSRF vulnerability is only exploitable in Jenkins 2.286 and earlier, LTS 2.277.1 and earlier. See the [LTS upgrade guide](https://www.jenkins.io/doc/upgrade-guide/2.277/#upgrading-to-jenkins-lts-2-277-2).
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | de.einsundeins.jenkins.plugins.failedjobdeactivator:failedJobDeactivator | <= 1.2.1 | none recorded |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Jenkins | Failed Job Deactivator | through 1.2.1 |