NetSight
medium5.8

CVE-2022-35956

update_by_case before 0.1.3 can be vulnerable to sql injection

Impact

Before version 0.1.3 `update_by_case` gem used custom sql strings, and it was not sanitized, making it vulnerable to sql injection. Upgrade to version >= 0.1.3 that uses `Arel` instead to construct the resulting sql statement, with sanitized sql.

Affected packages

EcosystemPackageAffectedFixed in
rubygemsupdate_by_case< 0.1.30.1.3

Affected products

VendorProductAffected versions
Update By Case ProjectUpdate By Case
before 0.1.3

Weakness classification

References