medium6.4
CVE-2022-36074
Nextcloud server is an open source personal cloud product.
Impact
Nextcloud server is an open source personal cloud product. Affected versions of this package are vulnerable to Information Exposure which fails to strip the Authorization header on HTTP downgrade. This can lead to account access exposure and compromise. It is recommended that the Nextcloud Server is upgraded to 23.0.7 or 24.0.3. It is recommended that the Nextcloud Enterprise Server is upgraded to 22.2.11, 23.0.7 or 24.0.3. There are no known workarounds for this issue.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Nextcloud | Nextcloud Enterprise Server | before 22.2.11 from 23.0.0 before 23.0.7 from 24.0.0 before 24.0.3 |
| Nextcloud | Nextcloud Server | before 23.0.7 from 24.0.0 before 24.0.3 |