NetSight
high7.5

CVE-2022-36125

Apache Avro Rust SDK corrupted data read can cause crash

Impact

It is possible to crash (panic) an application by providing a corrupted data to be read. This issue affects Rust applications using Apache Avro Rust SDK prior to 0.14.0 (previously known as avro-rs). Users should update to apache-avro version 0.14.0 which addresses this issue.

Affected packages

EcosystemPackageAffectedFixed in
rustapache-avro< 0.14.00.14.0

Affected products

VendorProductAffected versions
ApacheAvro
before 0.14.0

Weakness classification

References