NetSight
medium5.4

CVE-2022-3616

OctoRPKI crashes when max iterations is reached

Impact

### Impact Attackers can create long chains of CAs that would lead to OctoRPKI exceeding its max iterations parameter. In consequence it would cause the program to crash, preventing it from finishing the validation and leading to a denial of service. Credits to Donika Mirdita and Haya Shulman - Fraunhofer SIT, ATHENE, who discovered and reported this vulnerability. ### Specific Go Packages Affected github.com/cloudflare/cfrpki/cmd/octorpki ### Patches This issue is fixed in v1.4.4 ### Workarounds None.

Affected packages

EcosystemPackageAffectedFixed in
gogithub.com/cloudflare/cfrpki<= 1.4.31.4.4

Affected products

VendorProductAffected versions
CloudflareOctorpki
before 1.4.4

Weakness classification

References