NetSight
high7.5

CVE-2022-37734

graphql-java vulnerable to Denial of Service via GraphQL query that consumes CPU resources

Impact

graphql-java before 19.0, 18.3, and 17.4 is vulnerable to Denial of Service. An attacker send a malicious GraphQL query that consumes CPU resources. The fixed versions are 19.0, 18.3, and 17.4.

Affected packages

EcosystemPackageAffectedFixed in
mavencom.graphql-java:graphql-java< 17.417.4

Affected products

VendorProductAffected versions
Graphql-Java ProjectGraphql-Java
before 17.4
from 18.0 before 18.3

Weakness classification

References