NetSight
medium6.1

CVE-2022-3783

node-red-dashboard vulnerable to Cross-site Scripting

Impact

node-red-dashboard contains a cross-site scripting vulnerability. This issue affects some unknown processing of the file `components/ui-component/ui-component-ctrl.js` of the component ui_text Format Handler. The attack may be initiated remotely. The issue is patched in version 3.2.0.

Affected packages

EcosystemPackageAffectedFixed in
npmnode-red-dashboard< 3.2.03.2.0

Affected products

VendorProductAffected versions
NoderedNode-Red-Dashboard
before 3.2.0

Weakness classification

References