low3.0
CVE-2022-39211
Nextcloud server is an open source personal cloud platform.
Impact
Nextcloud server is an open source personal cloud platform. In affected versions it was found that locally running webservices can be found and requested erroneously. It is recommended that the Nextcloud Server is upgraded to 23.0.8 or 24.0.4. It is recommended that the Nextcloud Enterprise Server is upgraded to 22.2.10.4, 23.0.8 or 24.0.4. There are no known workarounds for this issue.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Nextcloud | Nextcloud Enterprise Server | before 22.2.10.4 from 23.0.0 before 23.0.8 from 24.0.0 before 24.0.4 |
| Nextcloud | Nextcloud Server | before 23.0.8 from 24.0.0 before 24.0.4 |
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-rmf9-w497-8cq8
- https://github.com/nextcloud/server/pull/32988
- https://github.com/nextcloud/server/pull/33031
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-rmf9-w497-8cq8
- https://github.com/nextcloud/server/pull/32988
- https://github.com/nextcloud/server/pull/33031