NetSight
high8.8

CVE-2022-39286

Execution with Unnecessary Privileges in JupyterApp

Impact

### Impact _What kind of vulnerability is it? Who is impacted?_ We’d like to disclose an arbitrary code execution vulnerability in `jupyter_core` that stems from `jupyter_core` executing untrusted files in the current working directory. This vulnerability allows one user to run code as another. ### Patches _Has the problem been patched? What versions should users upgrade to?_ Users should upgrade to `jupyter_core>=4.11.2`. ### Workarounds _Is there a way for users to fix or remediate the vulnerability without upgrading?_ No ### References _Are there any links users can visit to find out more?_ Similar advisory in [IPython](https://github.com/advisories/GHSA-pq7m-3gw7-gq5x)

Affected packages

EcosystemPackageAffectedFixed in
pipjupyter-core< 4.11.24.11.2

Affected products

VendorProductAffected versions
JupyterJupyter Core
before 4.11.2
DebianDebian Linux
Versions 10.0, 11.0
FedoraprojectFedora
Versions 36, 37

Weakness classification

References