NetSight
high7.7

CVE-2022-39297

melisplatform/melis-cms vulnerable to deserialization of untrusted data

Impact

### Impact Attackers can deserialize arbitrary data on affected versions of `melisplatform/melis-cms`, and ultimately leads to the execution of arbitrary PHP code on the system. Conducting this attack does not require authentication. Users should immediately upgrade to `melisplatform/melis-cms` >= 5.0.1. ### Patches This issue was addressed by restricting allowed classes when deserializing user-controlled data. ### References - https://github.com/melisplatform/melis-cms/commit/d124b2474699a679a24ec52620cadceb3d4cec11 ### For more information If you have any questions or comments about this advisory, you can contact: - The original reporters, by sending an email to vulnerability.research [at] sonarsource.com; - The maintainers, by opening an issue on this repository.

Affected packages

EcosystemPackageAffectedFixed in
composermelisplatform/melis-cms< 5.0.15.0.1

Affected products

VendorProductAffected versions
MelistechnologyMeliscms
before 5.0.1

Weakness classification

References