NetSight
medium5.9

CVE-2022-39341

OpenFGA Authorization Bypass via tupleset wildcard

Impact

### Overview During our internal security assessment, it was discovered that OpenFGA versions `v0.2.3` and prior are vulnerable to authorization bypass under certain conditions. ### Am I affected? You are affected by this vulnerability if you are using `openfga/openfga` version `v0.2.3` and you added a tuple with a wildcard (*) assigned to a tupleset relation (the right hand side of a ‘from’ statement). ### How to fix that? Upgrade to version `v0.2.4`. ### Backward Compatibility This update is not backward compatible with any authorization model that uses wildcard on a tupleset relation.

Affected packages

EcosystemPackageAffectedFixed in
gogithub.com/openfga/openfga<= 0.2.30.2.4

Affected products

VendorProductAffected versions
OpenfgaOpenfga
before 0.2.4

Weakness classification

References