medium4.9
CVE-2022-39383
KubeVela VelaUX APIserver has SSRF vulnerability
Impact
### Impact Users using the VelaUX APIServer could be affected by this vulnerability. When using Helm Chart as the component delivery method, the request address of the warehouse is not restricted, and there is a blind SSRF vulnerability. This issue is patched in 1.5.9 and 1.6.2. ### References Fix by: #5000 ### For more information If you have any questions or comments about this advisory: * Open an issue in [KubeVela repo](https://github.com/kubevela/kubevela) * Email us at [here](https://github.com/kubevela/kubevela#contact-us)
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| go | github.com/oam-dev/kubevela | < 1.5.9 | 1.5.9 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Linuxfoundation | Kubevela | before 1.5.9 from 1.6.0 before 1.6.2 |