NetSight
high8.8

CVE-2022-40955

Apache InLong vulnerable to Deserialization of Untrusted Data

Impact

In versions of Apache InLong prior to 1.3.0, an attacker with sufficient privileges to specify MySQL JDBC connection URL parameters and to write arbitrary data to the MySQL database, could cause this data to be deserialized by Apache InLong, potentially leading to Remote Code Execution on the Apache InLong server. Users are advised to upgrade to Apache InLong 1.3.0 or newer.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.inlong:inlong-common< 1.3.01.3.0

Affected products

VendorProductAffected versions
ApacheInlong
before 1.3.0

Weakness classification

References