NetSight
medium6.5

CVE-2022-41235

Jenkins WildFly Deployer Plugin vulnerable to path traversal

Impact

Jenkins WildFly Deployer Plugin 1.0.2 and earlier implements functionality that allows agent processes to read arbitrary files on the Jenkins controller file system. This vulnerability is only exploitable in Jenkins 2.318 and earlier, LTS 2.303.2 and earlier. See the [LTS upgrade guide](https://www.jenkins.io/doc/upgrade-guide/2.303/#upgrading-to-jenkins-lts-2-303-3).

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.jenkins-ci.plugins:wildfly-deployer<= 1.0.2none recorded

Affected products

VendorProductAffected versions
JenkinsWildfly Deployer
through 1.0.2

Weakness classification

References