NetSight
high8.8

CVE-2022-41239

Stored XSS vulnerability in Jenkins DotCi Plugin

Impact

DotCi Plugin 2.40.00 and earlier does not escape the GitHub user name parameter provided to commit notifications when displaying them in a build cause. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to submit crafted commit notifications to the `/githook/` endpoint (see also [SECURITY-2867](https://www.jenkins.io/security/advisory/2022-09-21/#SECURITY-2867)). This vulnerability is only exploitable in Jenkins 2.314 and earlier, LTS 2.303.1 and earlier. See the [LTS upgrade guide](https://www.jenkins.io/doc/upgrade-guide/2.303/#SECURITY-2452).

Affected packages

EcosystemPackageAffectedFixed in
mavencom.groupon.jenkins-ci.plugins:DotCi<= 2.40.00none recorded

Affected products

VendorProductAffected versions
JenkinsDotci
through 2.40.00

Weakness classification

References