high7.5
CVE-2022-41704
Apache XML Graphics Batik vulnerable to code execution via SVG.
Impact
A vulnerability in Batik of Apache XML Graphics allows an attacker to run untrusted Java code from an SVG. This issue affects Apache XML Graphics prior to 1.16. It is recommended to update to version 1.16.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.xmlgraphics:batik | < 1.16 | 1.16 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Batik | from 1.0 before 1.16 |
| Debian | Debian Linux | Versions 10.0, 11.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- http://www.openwall.com/lists/oss-security/2022/10/25/2
- https://lists.apache.org/thread/hplhx0o74jb7blj39fm4kw3otcnjd6xf
- https://lists.debian.org/debian-lts-announce/2022/10/msg00038.html
- https://security.gentoo.org/glsa/202401-11
- https://www.debian.org/security/2022/dsa-5264
- https://github.com/advisories/GHSA-r29w-r9ph-vm76
- https://nvd.nist.gov/vuln/detail/CVE-2022-41704
- https://github.com/apache/xmlgraphics-batik/commit/905f368b50c2567cf2c4869a0ab596a7b1b5125c
- https://issues.apache.org/jira/browse/BATIK-1338
- https://xmlgraphics.apache.org/security.html