NetSight
high7.5

CVE-2022-41957

muhammara and hummus vulnerable to Unchecked Return Value to NULL Pointer Dereference

Impact

### Impact The package muhammara before 2.6.2, from 3.0.0 and before 3.3.0; all versions of package hummus are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed. ### Patches It has been patched in 3.4.0 and has been backported to 2.6.2 There is no patch for hummus, currently ### Workarounds Do not process files from untrusted sources or update. Replace hummus with muhammara ### References https://github.com/julianhille/MuhammaraJS/pull/235 https://github.com/julianhille/MuhammaraJS/pull/238

Affected packages

EcosystemPackageAffectedFixed in
npmhummus< 2.6.2none recorded
npmmuhammara>= 3.0.0, < 3.4.03.4.0

Affected products

VendorProductAffected versions
Muhammara ProjectMuhammara
before 2.6.2
from 3.0.0 before 3.3.0
Hummus ProjectHummus
All versions

Weakness classification

References