critical9.8
CVE-2022-42468
Apache Flume vulnerable to remote code execution via deserialization of unsafe providerURL
Impact
Flume’s JMSSource class can be configured with a providerUrl parameter. A JNDI lookup is performed on this name without performing validation. This could result in untrusted data being deserialized, leading to remote code execution (RCE) attack when a configuration uses a JMS Source with an unsafe providerURL. This issue is fixed in version 1.11.0.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.flume.flume-ng-sources:flume-jms-source | < 1.11.0 | 1.11.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Flume | from 1.4.0 through 1.10.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://issues.apache.org/jira/browse/FLUME-3437
- https://lists.apache.org/thread/1ckhmp539zr2nd2rs45pocpywk2d9zvz
- https://lists.apache.org/thread/939wkx8o90bp6m2ht3t1sdyo1ncypl78
- https://github.com/advisories/GHSA-9w4g-fp9h-3q2v
- https://nvd.nist.gov/vuln/detail/CVE-2022-42468
- https://github.com/apache/flume/commit/eee179a09df405c1ab55ae25a53b76ca1050bb97