high8.8
CVE-2022-42735
Privilege escalation in Apache ShenYu
Impact
Improper Privilege Management vulnerability in Apache Software Foundation Apache ShenYu. ShenYu Admin allows low-privilege low-level administrators create users with higher privileges than their own. This issue affects Apache ShenYu: 2.5.0. Upgrade to Apache ShenYu 2.5.1 or apply patch https://github.com/apache/shenyu/pull/3958.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.shenyu:shenyu-admin | < 2.5.1 | 2.5.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Shenyu | Version 2.5.0 |