NetSight
high7.5

CVE-2022-42890

Untrusted code execution in Apache XML Graphics Batik

Impact

A vulnerability in Batik of Apache XML Graphics allows an attacker to run Java code from untrusted SVG via JavaScript. This issue affects Apache XML Graphics prior to 1.16. Users are recommended to upgrade to version 1.16.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.xmlgraphics:batik< 1.161.16
mavenorg.apache.xmlgraphics:batik-bridge< 1.161.16

Affected products

VendorProductAffected versions
ApacheBatik
from 1.0 before 1.16
DebianDebian Linux
Versions 10.0, 11.0

Weakness classification

References