NetSight
high7.8

CVE-2022-43484

TERASOLUNA Server Framework vulnerable to ClassLoader manipulation

Impact

TERASOLUNA Global Framework 1.0.0 (Public review version) and TERASOLUNA Server Framework for Java (Rich) 2.0.0.2 to 2.0.5.1 are vulnerable to ClassLoader manipulation due to using the old version of Spring Framework which contains the vulnerability. The vulnerability is caused by an improper input validation issue in the binding mechanism of Spring MVC. By the application processing a specially crafted file, arbitrary code may be executed with the privileges of the application. When using TERASOLUNA Global Framework 1.0.0 (Public review version), update to TERASOLUNA Server Framework for Java 5.7.1.SP1 (using Spring Framework 5.3.18). This vulnerability alone can be addressed by updating to TERASOLUNA Global Framework 1.0.1 (using Spring Framework 3.2.10) or later.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.terasoluna.gfw:terasoluna-gfw-common< 1.0.1.RELEASE1.0.1.RELEASE

Affected products

VendorProductAffected versions
NttdataTerasoluna Global Framework
Version 1.0.0
NttdataTerasoluna Server Framework For Java \(Rich\)
from 2.0.0.2 through 2.0.5.1

Weakness classification

References