NetSight
medium6.3

CVE-2022-43690

Concrete CMS vulnerable to Improper Authentication

Impact

Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2 did not use strict comparison for the legacy_salt so that limited authentication bypass could occur if using this functionality. Remediate by updating to Concrete CMS 9.1.3+ or 8.5.10+.

Affected packages

EcosystemPackageAffectedFixed in
composerconcrete5/concrete5< 8.5.108.5.10

Affected products

VendorProductAffected versions
ConcretecmsConcrete Cms
before 8.5.10
from 9.0.0 through 9.1.2

Weakness classification

References