NetSight
medium4.8

CVE-2022-43695

Concrete CMS Cross-site Scripting vulnerability

Impact

Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2 is vulnerable to Stored Cross-Site Scripting (XSS) in dashboard/system/express/entities/associations because Concrete CMS allows association with an entity name that doesn’t exist or, if it does exist, contains XSS since it was not properly sanitized. Remediate by updating to Concrete CMS 9.1.3+ or 8.5.10+.

Affected packages

EcosystemPackageAffectedFixed in
composerconcrete5/concrete5< 8.5.108.5.10

Affected products

VendorProductAffected versions
ConcretecmsConcrete Cms
before 8.5.10
from 9.0.0 through 9.1.2

Weakness classification

References