NetSight
medium6.5

CVE-2022-44644

Apache Linkis vulnerable to Exposure of Sensitive Information

Impact

In Apache Linkis <=1.3.0 when used with the MySQL Connector/J, an authenticated attacker could read arbitrary local file by connecting a rogue mysql server, By adding allowLoadLocalInfile to true in the jdbc parameter. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users upgrade the version of Linkis to version 1.3.1

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.linkis:linkis< 1.3.11.3.1

Affected products

VendorProductAffected versions
ApacheLinkis
through 1.3.0

Weakness classification

References