high8.8
CVE-2022-44645
Apache Linkis contains Deserialization of Untrusted Data
Impact
In Apache Linkis <=1.3.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures new datasource with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users to upgrade the version of Linkis to version 1.3.1.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.linkis:linkis | < 1.3.1 | 1.3.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Linkis | through 1.3.0 |