critical9.8
CVE-2022-45046
camel-ldap component allows LDAP Injection when using the filter option
Impact
The camel-ldap component allows LDAP Injection when using the filter option. Users are recommended to either move to the Camel-Spring-Ldap component (which is not affected) or upgrade to 3.14.6 or 3.18.4.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.camel:camel-ldap | < 3.14.6 | 3.14.6 |