critical9.8
CVE-2022-45135
Apache Cocoon SQL Injection vulnerability
Impact
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Cocoon. This issue affects Apache Cocoon: from 2.2.0 before 2.3.0. Users are recommended to upgrade to version 2.3.0, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.cocoon:cocoon | >= 2.2.0, < 2.3.0 | 2.3.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Cocoon | from 2.2.0 before 2.3.0 |