NetSight
high6.5

CVE-2022-46651

Apache Airflow information disclosure vulnerability

Impact

Apache Airflow, versions before 2.6.3, is affected by a vulnerability that allows an unauthorized actor to gain access to sensitive information in Connection edit view. This vulnerability is considered low since it requires someone with access to Connection resources specifically updating the connection to exploit it. Users should upgrade to version 2.6.3 or later which has removed the vulnerability.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-airflow< 2.6.32.6.3

Affected products

VendorProductAffected versions
ApacheAirflow
before 2.6.3

Weakness classification

References