high8.8
CVE-2022-46792
Hasura GraphQL Engine before 2.15.2 mishandles row-level authorization in the Update Many API for Postgres backends.
Impact
Hasura GraphQL Engine before 2.15.2 mishandles row-level authorization in the Update Many API for Postgres backends. The fixed versions are 2.10.2, 2.11.3, 2.12.1, 2.13.2, 2.14.1, and 2.15.2. (Versions before 2.10.0 are unaffected.)
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Hasura | Graphql Engine | from 2.10.0 before 2.10.2 from 2.11.0 before 2.11.3 from 2.13.0 before 2.13.2 from 2.15.0 before 2.15.2 Versions 2.12.0, 2.14.0 |
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/hasura/graphql-engine/security/advisories/GHSA-g7mj-g7f4-hgrg
- https://groups.google.com/g/hasura-security-announce/c/kzK-uPAKGUU
- https://hasura.io/blog/critical-vulnerability-in-hasuras-graphql-engine-v2-10-0/
- https://github.com/hasura/graphql-engine/security/advisories/GHSA-g7mj-g7f4-hgrg
- https://groups.google.com/g/hasura-security-announce/c/kzK-uPAKGUU
- https://hasura.io/blog/critical-vulnerability-in-hasuras-graphql-engine-v2-10-0/