NetSight
medium6.1

CVE-2022-46907

Apache JSPWiki vulnerable to cross-site scripting on several plugins

Impact

A carefully crafted request on several JSPWiki plugins could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.0 or later.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.jspwiki:jspwiki-main< 2.12.02.12.0
mavenorg.apache.jspwiki:jspwiki-war< 2.12.02.12.0

Affected products

VendorProductAffected versions
ApacheJspwiki
before 2.12.0

Weakness classification

References